So while "application message" is certainly a term used with
mqtt it could be used outside it as well. I suggest to either rename it to include
mqtt (something like mqtt-application-message) or get rid of it at all if it does add enough value.
What do you think?